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CREATIVE TECHNIQUES #1:  ADDING TEXTURES AND REPLACING SKIES  BY MICHAEL SMYTH 

 
In this tutorial we will look at some of the most common and creative techniques available to 

enhance images and add a touch of creativity to photography. 
 
ISN’T THIS CHEATING ? 
 
Manipulating images and using creative techniques to create images that reflect your vision of the world 
are nothing new and have been practised since the beginning of photography.  In-camera double 
exposure can create similar effects to the texture technique and darkroom techniques that replace 
elements of an image have been used for well over a hundred years by skilled photographers.  The new 
digital techniques arising from digital capture and processing have made these techniques more widely 
accessible.  In other words, no, it isn’t cheating ! 
 

                                                        
Above:  In-camera double exposure.    Above:  Replaced sky or montage 

 
 
TECHNIQUE #1  ADDING TEXTURES TO IMAGES 
 
Note:  for further information on some of the Photoshop techniques using layers, refer to the tutorial called 
“Introduction to Layers”  available elsewhere on the Phototutor website. 
 
Adding a texture to an image can often add a sense of age, character or abstraction to an otherwise 
traditional image. 
 
To use this technique you will need suitable images to use as the base, or background for the 
photograph, plus a series of texture images to use as the textural element.  Textures can be 
photographed from almost any background and can be macro images, close up images of small 
textures, or larger scale textures of walls, concrete, fabric or the like.  The image should be evenly lit and 
equally in focus across the image area you intend to use.  You can crop the texture image during 
processing to eliminate any unwanted elements or out of focus parts prior to opening the image. 
 
To begin, first select your candidate image for the background and process the RAW file using your 
normal settings, to give a good sharp image.  Open in Photoshop (or Photoshop Elements) using your 
default size.  For best results open your image at the printer resolution – 360 dpi for Epson printers and 300 
dpi for Canon and HP printers.  Starting with an image at the correct size for printing will save resizing 
later. 
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TECHNIQUE #1  ADDING TEXTURES TO IMAGES continued 
 
For this technique, it is desirable but not mandatory that the two images be similar in size.  Therefore a 
small area of texture can be stretched to cover a larger background. 
 
Secondly, choose your texture image, process, crop and open in Photoshop.  You will have two images 
open and we will be adding the texture image as a layer on top of the background image. 
 

          
 
Above:  The background image   Above:  the texture image to be used 
 
Next:  Click on the texture image to make it active and go to the Select menu header and choose “All”.  
You should see a line of “marching ants” (called a Marquee) around the perimeter of the image area.  
This shows that the image has been selected.  
 
Next: go to the Edit menu header and choose “Copy”.  This copies the selected image to the clipboard.  
 
Next: click on the background image to make it active (or you can close the texture image as it is no 
longer needed).  Now go to the Edit menu header and choose “Paste”   
 

                                     
 
Select>All to make a selection Edit>Copy makes a copy  Edit> Paste adds the  
of the texture image.   of the texture image   Selected copy as a new 
          layer on top of the 

background image. 
 
The background should now be totally obscured by the texture image.  It might be that the texture layer 
is either larger or smaller than the background image.  We will address this next. 
 
If your texture image is larger or smaller than the background image we will need to resize it before 
proceeding.  Check in your layers palette to see that the texture layer is selected – it will be highlighted.  
If you can’t see the layers palette, go to the Window menu header and make sure that the “Layers” label 
is ticked.  
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TECHNIQUE #1  ADDING TEXTURES TO IMAGES continued 
 
Having checked that you have selected the texture layer, next go to the Edit menu header and choose 
“Transform”  and then from the fly out menu, select “Scale” ( see below). 
 

  
 
Above:  the Edit>Transform>Scale menu.  Note at bottom right the texture layer is selected – i.e. 
highlighted. 
 
With this option selected you have two options:  (1) To retain the proportions of the texture layer, you will 
need to go to the contextual menu panel that will appear at the top of the image area.  In between the 
boxes for “W” (width) and “H” (height)  click on the chain symbol to lock the proportions together. 
 

 
 
Above: The transform options panel. 
 
If it is not required to lock the proportions together (it isn’t always necessary), ignore the step above and 
go to the image area.  You will see a marquee around the texture image area.  At each corner and in 
the centre of each edge there are small “handles”.  Grab one of the corner handles (Click and hold with 
the left mouse button) and then drag the corner of the image until it reaches the corner of your 
background image.  By default Photoshop will snap the image to the boundaries.  Do this with each 
corner until the texture image covers the background image.  (To turn on snap modes, go to View>Snap 
to> and tick Document Bounds) 
 
When complete, either hit the Enter key, or click on the tick icon in the options panel (later versions of 
Photoshop only).  The texture image is now the same size as the background and we can now adjust the 
blending to complete the process. 
 
To blend the texture with the background image we will use a combination of two layer adjustments: 
 
The Blend mode (which determines how the image information is combined with the background layer 
(see “Introduction to Layers” for a detailed explanation), AND  The Opacity of the texture layer. 
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TECHNIQUE #1  ADDING TEXTURES TO IMAGES continued 
 
To adjust the blending of the texture Layer, I suggest you start by using the “Overlay” blend mode.  Make 
sure your texture layer is still selected (it will be highlighted in the layers panel).  Then click on the drop 
down menu that will be labelled “Normal”  (This is the default blend mode). 

 
 Far Left: Layers Palette with 
texture layer active and 
“Normal” blend mode. 
 
 
Left:  Blend mode drop down 
menu and “Overlay” selected. 
 
 
 
 

 
Having selected the “Overlay” 
Blend mode, part of your 
Background image will now  
be visible. 
 
Next: to “fine tune” the blending, select the Opacity slider (located to the right of the Blend mode drop 
down menu.  Slide the slider to the left, from 100% towards 0%.  Note:  100% opaque means the top layer 
is fully opaque (depending on the blend mode) and 0% means it is completely transparent. 
 
By choosing an opacity and selecting from a suitable blend mode (usually Overlay, Soft Light or Hard 
Light) will give the best results.  Try different blend modes by clicking on the drop down menu and 
choosing one of the other methods.  You will need to adjust the opacity for each different blend mode. 
 
To refine the image, you can add a layer mask to the texture layer and paint black onto the mask with 
varying opacity to selectively apply where the texture is added.  In the image below the name badge 
was partially masked to keep the lettering clear.  ( See “Introduction to Layers” for more details on 
applying and using masks). 
 

        
Above:  The final image using Overlay blend and showing the layers stack including special filters. 

 
The image can be further refined with adjustment layers and special effect filters to personal taste.  When 
complete, save as a Photoshop (.PSD) or TIFF file with layers intact to allow for future editing. 
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TECHNIQUE #2:  REPLACING SKIES (OR OTHER ELEMENTS)  
 
Often the image we capture has a poor or overcast sky that would benefit from adding a more dramatic 
element from another image.  This technique dates back to the beginning of photography and has been 
made more accessible with modern digital processing techniques. 
 
When selecting an alternative sky to add to an image it is important that the new sky is similar in lighting 
and colour temperature to the base image.  Adding a sunset sky to a background obviously captured in 
the middle of the day is going to look very wrong.  Likewise the direction of the lighting and shadows 
needs to be consistent. 
 
To begin, first select your background image and a suitable sky to replace the original. 
 

                                        
 
Above:  Base image with a plain sky   Above:  The sky and background to replace 
Old church in Puerto Varas, Chile   the sky in the church image – note the different 
       Image orientation.  Volcano Osorno in Southern Chile 
 
The base image was taken in the morning with a strong side light illuminating from the left hand side of 
the building.  The volcano and sky were photographed on another day in the same region, although this 
does not have any real relevance to the final image. 
 
To begin: first process your images in your RAW processing software and include sharpening, noise 
reduction and other processing as you would for a normal image.  Open both images in Photoshop (or 
Photoshop Elements).   
 
Next, choose the background image – in this case the church.  Duplicate the background layer by 
dragging the background layer to the new layer icon at the bottom of the layers palette. 

   
Left:  The new layer icon is the icon that looks like a folded over 
sheet of paper.   
 

Alternatively, go to the Layer menu and choose Layer>Duplicate Layer , then click OK on the pop up 
menu box that asks you to name the new layer.  By default it will be called “Background copy”.  This is 
fine for our purposes.   
 
Note:  Duplicating the background layer helps us by enabling us to have a copy of the background layer 
in case we need to repeat the step.  Advanced users can work directly on the Background layer. 
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TECHNIQUE #2:  REPLACING SKIES (OR OTHER ELEMENTS) continued 
 
If working on the background layer and not working on a duplicate, first click on the padlock icon on the 
background layer (double click if using older versions of Photoshop) to enable editing of this layer. 
 
Next, we need to make a selection of the sky in our background layer so we can mask it out and allow 
our new sky to be visible.  The most effective toll for making a selection of the sky is the Quick Selection 
tool.  This is the tool that looks like a paintbrush with a dotted line around it. 
 

Left:  the Quick Selection tool.  Use a small 
radius for more accurate selections and use 
the + or – brush buttons in the contextual 
toolbar at the top of the image to add to or 
subtract from the selection, in order to get a 
good selection. 
 
Making an accurate selection is critical to the 
effectiveness of the process, so take time to 
get it right. 

 
Once you have a good selection of the sky, make sure you save this selection for possible reuse by going 
to the Select menu and then Save Selection, (Select>Save Selection).  In the pop up box, make sure that 
under Channel the word “New” is showing and in the Name box, type “Sky” or something else 
meaningful.  Then click OK to save the selection. 

 
Left:  The Save Selection menu box.  This saves your selection in 
case you need to use it again.  If you make further refinements to 
the selection (see below) you can re save this selection by 
repeating the steps above, except that instead of “New” as the 
Channel, click on the drop down menu and choose “Sky” as your 
previously saved selection.  Ensure the option “Replace Channel” 
at the bottom of the box is selected. 
 
You will need to refine the edge of the selection, depending on 
how clearly defined the boundary is between sky and the base 
of the image.   

 
As an alternative method of making the selection, if your image has a clearly defined sky, you can use 
the Select>Color Range tool.  This tool allows you to make a selection using the colour or tonal range in 
the image.  This is effective where the sky is the only or majority part of the image that is blue.  (To see 
more on using the various selection tolls, see the separate tutorial called “Making Selections in 
Photoshop” on the Phototutor website) 
 
Under the options, choose “Selected Colors” and select the + eyedropper.  Set the “Fuzziness” slider to a 

low value – around 15 (this determines the range of colours outside of the 
selected colour that will be included in the selection).  Use the + eyedropper 
and click on parts of the sky in the thumbnail view in the menu box.  You will 
see progressively larger parts of the sky selected.  Do not click on anything 
other than the sky, otherwise your selection will include other colours and you 
will have to select the – eyedropper to de select these areas. 
 
Note:  regardless of which selection method you choose you will not be able to 
make a perfect selection without refining the selection. 
 
Once you have a good selection, click OK and you will return to the image.  
You will now see the dotted line of the selection around the edge of the sky. 
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TECHNIQUE #2:  REPLACING SKIES (OR OTHER ELEMENTS) continued 
 
After making your selection, it will be necessary to refine the edge of the selection, in order to make it as 
seamless as possible.   
 
With your selection active having used either the Quick Selection tool or the Color Range tool, first 
choose either the “Quick Select”, “Lasso” or “Rectangular Marquee” selection tool to activate the 
contextual menu at the top of the image.  Next, choose the “Refine Edge” tool by clicking on the box 
called “Refine Edge”.  Note:  if you are using an older version of Photoshop or Elements, you may not 
have this option – this is one of the many useful tool available in later versions of the software and is a 
good reason to upgrade.   
 

Left:  The Selection contextual menu. 
 

 
Once you have the “Refine Edge” menu activated, you will see a new menu box.  Click on the option for 
“Smart Radius” and then zoom in on the edge of your mask to paint along the boundary of the selection. 

 
Far Left:  The Refine Edge 
dialogue box.        
 
You can use the Smart 
Radius tool to refine the 
edge of your selection.  
Click on OK when 
completing a part to see 
the effectiveness.  Click 
on Refine Edge again to 
continue. 
 
Using the other tools 
allows fine control over 
the selection. 
 
Use Smooth to smooth out 
jagged selections, 
 
Use Contrast to increase 
the sharpness at the edge 
of the selection 
 

Use Feather to soften the selection edge, or Shift Edge to move the edge of the selection inside or outside 
of the edge.  When done, click OK and then re save the selection (as noted above).   
 
Now we have the selection complete, except that the sky has been selected, when what we really want 
is everything else.  To invert the Selection, go to Select>Inverse.  This inverts the selection so that what we 
have selected is what we want to remain visible.  
 
Next, with the selection still active on your background layer (or Background copy) click on the “Add 
Layer Mask” icon on the Layers palette to add a layer mask to the active layer. 

 
Left:  The “Add Layer mask” icon - This is the rectangle with a 
black circle in the centre. 
 

This loads the selection as a mask onto the active layer. 
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TECHNIQUE #2:  REPLACING SKIES (OR OTHER ELEMENTS) continued 
 
Once the layer mask is added to the layer, the sky should appear as black and the base of the image 
should be white (“White conceals and Black Reveals is the mantra for using masks”).   
 
We want our sky to show as black, so if the mask is the opposite way round, go to the properties tab, click 
on the mask icon and then choose “Invert” to reverse the masked areas.  (This is in case you missed 
inverting the mask, as noted above. 
 

Left:  The layers properties tab.  Choose “Invert” to change white to black 
and black to white. 
 
Once the selection has been loaded into the mask, you can access the 
Refine Edge tools directly from this panel, should you need to make further 
changes to the mask.  
 
Note:  You can also paint directly onto the mask in the layers palette using 
the brush tool and either black or white to add or remove parts of the mask, 
or even more simply, load the mask over the image for a more magnified 
view of the mask. 
 
To load the mask over the image, first select the mask by clicking on the 
layer mask box next to the image thumbnail –this is the box showing black 
and white.  When selected it will show a fine line around the mask icon. 
 

 
Left:  The layer mask selected 
– note the line around the 
icon. 
 
To load the mask over the 
image, hold down the Alt key 
(Mac: Option) and with your 

mouse, click on the mask icon.  The mask is now loaded over your image 
and will appear as a black and white.  
 
 

 
To modify the mask, you will need to choose the brush tool 
and either black or white as the active colours from the left 
hand tools palette. 
 
Left:  The brush tool, the Foreground and background 
colours and the contextual menu.   
 
Note that the opacity of the brush can be modified to 
make a partially masked area.  To swap between black 
and white, use the “X” key.   
 
When you have finished modifying the mask, if in fact you 
need to modify it further, move your mouse over the mask 
icon in the layers palette again, hold down Alt and click on 
the mask icon to remove it from overlaying the image. 
 
If you are unsure of doing these modifications, I suggest you 
make a duplicate of this layer by repeating the steps 
outlined above for duplicating layers.  
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TECHNIQUE #2:  REPLACING SKIES (OR OTHER ELEMENTS) continued 
 
Now that we have an accurate mask on our background image, it is time to add in the replacement sky.  
I suggest you save your background image file with a new name at this stage, to ensure that everything is 
available in case of any problems during the next steps. 
 
The next step is to go to the sky image we are going to add to replace the existing sky.  Go to the sky 
image, then go to the “Select” menu, choose “Select All”, then go to Edit>Copy to load the image onto 
the Clipboard.  These are the same steps as used for the adding a texture layer – see page 2 of this 
tutorial.  You can also simply drag the sky layer onto your background layer using the “Move” tool 
 
Next go back to your background image and then go to Edit>Paste.  This adds the sky as a new layer in 
your image.  Depending on which layer you had selected when you pasted the new layer, chances are 
the sky layer will be sitting on top of your background layer. 
 
We want the sky to be sitting below the background layer with the mask.  Now go to the layers palette 
and click on the sky layer.  Next, drag it downwards until a line appears below the background layer and 
release the sky layer.  The sky should now be sitting below the masked background layer.   
 

    
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Above:  original layer order after pasting   Above:  The new layer order after moving 
 
Once the sky layer is in place, select the Move Tool (top tool in the tools menu  - it looks like a 4 
directional arrow).  Use the move tool to drag the layer around to position it where you want it in the 
image.  To modify the size of the layer, use the transform tools as outlined in the Texture tutorial above. 
 
At this point you might find that your mask on the background layer is not perfect.  Go back to the layer 
mask and modify as noted above. 
 
Once you have the position of the new sky and the masking complete, you can further refine the layers 
by applying adjustments to either all layers (the new adjustments sit on top of all layers) or to individual 
layers (by putting the adjustment above that layer and adding a Clipping Mask). 
 
Applying adjustments to all layers:  Regardless of how many layers you have in an image, applying an 
adjustment layer to the top of the layers stack will generally apply that adjustment to all layers below.  
There are exceptions, however.  If your layer is blended to anything other than Normal blending, the 
adjustment may have a different effect.  Blend modes such as Luminosity will not be affected by any 
colour adjustment, as the layer is only contributing Luminosity (brightness) information to the image. 
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TECHNIQUE #2:  REPLACING SKIES (OR OTHER ELEMENTS) continued 
 
Applying adjustments to selected layers:  If you only want to apply an adjustment to a particular layer, 
and not those above or below that layer, you will need to position the adjustment layer directly above 
the layer being adjusted and then apply a Clipping Mask  to confine the adjustment to that layer only. 
 
A Clipping Mask (the icon is a small square with a downwards pointing arrow, is found at the bottom of 
the layers properties panel) applies the adjustment only to the layer immediately below that adjustment. 
 

Left:  An Adjustment layer with the Clipping Mask activated. 
 
The Clipping Mask restricts the effect of that adjustment to the layer 
immediately below. 
 
The Clipping Mask Icon is the small square with a downward pointing arrow 
that is at the bottom of the adjustment layer properties window (CS6 and 
Photoshop CC only.  The clipping mask on older versions of Photoshop can 
be found by Right Mouse clicking on the adjustment layer itself and 
selecting it from the drop down menu.) 
 
 
 
 
 
 

 

                                       
 
Above:  An adjustment layer  applied to all layers  Above:  An adjustment clipped 
        to the layer below.   
 
When complete, save as a Photoshop (.PSD) file or TIFF to retain layers for any future editing. 
 
By saving as a layered Photoshop or TIFF file you have the option of re editing at a future date.  If you no 
longer require the layers, you can flatten all layers by going to Layer>Flatten Image and then saving in 
your preferred file format. 
 
© Michael Smyth 2014 
 


